[elrepo] Bug in kernel-ml.2.6.37 package?

Kenni Lund kenni at kelu.dk
Thu Feb 3 14:33:53 EST 2011

Hi list

I ran into a issue yesterday, which might be a bug in the
kernel-ml.2.6.37 package, so I though I would post it here instead of
just ignorering it.

I had an almost new and up-to-date CentOS 5.5 x86_64 installation on a
MD RAID1 + LVM and upgraded the motherboard to a newer one, which had
a e1000e-based onboard NIC. Since the NIC wasn't supported in the
stock kernel, I manually downloaded the
"kernel-ml-2.6.37-0.1.el5.elrepo.x86_64.rpm" package and installed it
on the machine with "rpm -Uvh". The installation didn't give me any
errors, so I rebooted the machine and selected the new 2.6.37 kernel.
Unfortunately, it didn't boot, instead it complained about not being
able to find the volume group, followed by a kernel panic. For the
record, the boot partition is directly on /dev/md0, while the root
partition is on the LVM - so MD was working, but not LVM.

I booted the stock kernel, tried to remove/reinstall the 2.6.37 kernel
and reboot multiple times, checked the grub config, etc, but with no

Now I manually downloaded the latest e1000e package
"kmod-e1000e-1.2.20_NAPI-1.el5.elrepo.x86_64.rpm", installed it with
"rpm -Uvh", and got the system online with the stock kernel. After
configuring the elrepo-kernel repository, I decided to give the
"kernel-ml-2.6.35-10.1.el5.elrepo.x86_64.rpm" a go...I installed it
with yum - no additional dependencies were pulled - and it worked in
the first try.

Just for fun, I now tried to reboot and select the 2.6.37 kernel
again....and now it booted with no LVM issues...

Has anyone else tried to install the 2.6.37 kernel-ml package on a
stock install of CentOS 5.5 (with all updates), with no previous
kernel-ml packages and/or kmod-modules installed?

Best regards

More information about the elrepo mailing list